Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Agua Prieta Power Outage
Incident Report for Hunter Douglas IT
Resolved
Power has been restored in Agua Prieta plant A.
Posted Jul 20, 2023 - 21:20 MDT
Identified
Agua Prieta has experienced a partial power outage affecting plant A and the local power company is investigating. No ETR.
Posted Jul 18, 2023 - 17:49 MDT
This incident affected: Agua Prieta (ME/MII, Network, Shipping, Power).