Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Appleton Network Outage
Incident Report for Hunter Douglas IT
Resolved
The external vendor has resolved the network outage affecting Appleton.
Posted Aug 22, 2023 - 15:45 MDT
Identified
Appleton is experiencing a network outage. We have escalated a ticket with the 3rd party vendor (Spectrum).
Posted Aug 22, 2023 - 14:02 MDT
This incident affected: Appleton (Network).