Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal

Rosarito (ILM) ME/MII Slowness

Incident Report for Hunter Douglas IT

Resolved

Support teams have resolved the slowness.
Posted Aug 03, 2023 - 22:57 MDT

Investigating

We are currently investigating ME/MII slowness affecting Rosarito. Support teams are engaged.
Posted Aug 03, 2023 - 22:40 MDT
This incident affected: Rosarito (ME/MII).