Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal

SE9 Outage

Incident Report for Hunter Douglas IT

Resolved

Support teams have resolved the SE9 partial outage. Users are now able to create goods receipts.
Posted Jun 05, 2023 - 10:17 MDT

Investigating

We are experiencing a partial SE9 outage. Users are getting errors when creating good receipts.
Posted Jun 05, 2023 - 07:46 MDT
This incident affected: SE9.