Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal

{HD All} Attention (Informational): Global Protect BLUVPN no longer available

Incident Report for Hunter Douglas IT

Resolved

Testing resolved.
Posted Dec 28, 2023 - 12:39 MST

Investigating

Testing
Posted Dec 28, 2023 - 12:29 MST
This incident affected: Testing (Testing).