Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
7/9 MTY Power Outages
Incident Report for Hunter Douglas IT
Resolved
This incident has been resolved.
Posted Jul 09, 2024 - 10:54 MDT
Identified
Problem: Monterrey has experienced a power outage that is affecting the entire site. No ETR.

Next Update: When power is restored.
Posted Jul 09, 2024 - 09:40 MDT
This incident affected: Monterrey (Power).