Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Rosarito (ILM) Power Outage
Incident Report for Hunter Douglas IT
Resolved
Rosarito is currently running on a work around.
Posted Aug 21, 2023 - 11:49 MDT
Investigating
Rosarito is currently experiencing a power outage. The site is currently running off generator.
Posted Aug 20, 2023 - 20:50 MDT
This incident affected: Rosarito (ME/MII, Network, Shipping, Legacy shop floor, Power).