Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Agua Prieta Internet Outage
Incident Report for Hunter Douglas IT
Resolved
The third party vendor has resolved the internet outage affecting Agua Prieta.
Posted Aug 05, 2023 - 17:57 MDT
Update
Agua Prieta is still experiencing an internet outage and the third party vendor continues to work towards a resolution. ETR is 8:00 p.m. MT.
Posted Aug 05, 2023 - 17:23 MDT
Update
The third party vendor continues to work towards a resolution of the internet outage affecting Agua Prieta. ETR is 8:00 p.m. MT.
Posted Aug 05, 2023 - 15:20 MDT
Update
The third party vendor's current estimate to resolve the internet outage affecting Agua Prieta is 8:00 p.m. MT.
Posted Aug 05, 2023 - 13:17 MDT
Investigating
We are currently investigating an internet outage in Agua Prieta and a ticket has been opened with the third party vendor. No ETR.
Posted Aug 05, 2023 - 11:23 MDT
This incident affected: Agua Prieta (Network).