Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Agua Prieta Network Outage
Incident Report for Hunter Douglas IT
Resolved
The external vendor has resolved the network outage affecting Agua Prieta. Support will continue to closely monitor but please contact the Service Desk if any new issues arise.
Posted Sep 04, 2023 - 07:32 MDT
Investigating
Agua Prieta is experiencing a network outage and a ticket has been opened with the external vendor. No ETR.
Posted Sep 04, 2023 - 05:30 MDT
This incident affected: Agua Prieta (Network).