Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
McKinney Power Outage
Incident Report for Hunter Douglas IT
Resolved
Power has been restored in McKinney. Support will continue to closely monitor but please contact the Service Desk if any new issues arise.
Posted Jun 16, 2023 - 06:23 MDT
Identified
McKinney has experienced a power outage and the local power company is investigating. No ETR.
Posted Jun 15, 2023 - 22:38 MDT
This incident affected: McKinney (Network, ME/MII, Shipping, Power).