Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Test Incident
Incident Report for Hunter Douglas IT
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 10:53 MST
Update
We are continuing to investigate this issue.
Posted Feb 09, 2024 - 10:53 MST
Investigating
We are currently investigating this issue.
Posted Feb 09, 2024 - 09:59 MST