Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
SE9 Outage
Incident Report for Hunter Douglas IT
Resolved
Support teams and OneSource have resolved this issue. Users are now able to create Sales Orders and Invoices.
Posted Jun 07, 2023 - 12:57 MDT
Identified
Support teams have identified the issues with OneSource. We have escalated a ticket with their support.
Posted Jun 06, 2023 - 20:18 MDT
Investigating
We are currently investigating errors when Customer Service saves orders.
Posted Jun 06, 2023 - 17:00 MDT
This incident affected: SE9.