Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Investigate and major
Incident Report for Hunter Douglas IT
Postmortem

Rreeererfgg

Posted Feb 09, 2024 - 04:27 MST

Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 04:24 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 09, 2024 - 04:24 MST
Update
We are continuing to investigate this issue.
Posted Feb 09, 2024 - 04:22 MST
Investigating
Investigating major
Posted Feb 09, 2024 - 04:04 MST
This incident affected: Testing (Testing).