Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Talk Desk Outage
Incident Report for Hunter Douglas IT
Resolved
The 3rd party vendor, Talk Desk, has resolved the system outage. Inbound and outbound calls are successful. Agent statuses and the dashboard are operational. Support will continue to closely monitor but please contact the Service Desk if any new issues arise.
Posted Jun 14, 2023 - 15:08 MDT
Investigating
The 3rd party vendor, Talk Desk, is experiencing a system outage. This outage is affecting inbound and outbound calls, agent statuses, and the dashboard. Talk Desk support is currently engaged and working on the issue. No ETR.
Posted Jun 14, 2023 - 14:34 MDT