Resolved: Power for all buildings in Monterrey has been restored, and production has resumed. Support will continue to closely monitor but please contact the Service Desk if any new issues arise.
Posted Jul 09, 2024 - 07:32 MDT
Investigating
Problem: Monterrey has experienced a power outage that is affecting the entire site. No ETR.