Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal

JSM: auto-assignment of tickets when Service Recipient creates ticket in agent portal

Incident Report for Hunter Douglas IT

Resolved

This incident has been resolved.
Posted Apr 11, 2024 - 11:37 MDT

Investigating

testing
Posted Apr 11, 2024 - 11:29 MDT
This incident affected: Testing (Testing).