Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
6/5 Monterrey Power outage
Incident Report for Hunter Douglas IT
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 08:29 MDT
Investigating
Monterrey has experienced a power outage affecting the entire site. No ETR.
Posted Jun 05, 2024 - 23:14 MDT
This incident affected: Monterrey (Power).