Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal

Shop Floor Jira Change: ITSF-4716: Revert AWS code to remove Duplicate check

Incident Report for Hunter Douglas IT

Resolved

This incident has been resolved.
Posted May 31, 2024 - 08:15 MDT

Investigating

We are currently investigating MII slowness affecting Rosarito.
Posted May 30, 2024 - 18:22 MDT
This incident affected: Rosarito (ME/MII).