Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Talk Desk Outage
Incident Report for Hunter Douglas IT
Resolved
Support teams, Lumen, and Talk Desk (external vendors) have resolved the phone issue.
Posted May 17, 2023 - 13:28 MDT
Update
Support teams, Lumen, and Talk Desk (external vendors) continue to work on the issue.
Posted May 17, 2023 - 12:09 MDT
Update
Support teams, Lumen, and Talk Desk (external vendors) continue to troubleshoot the issue. While investigating, support teams found it is also affecting inbound calls to toll-free numbers.
Posted May 17, 2023 - 09:44 MDT
Investigating
We are currently investigating an issue with inbound Talk Desk calls affecting all locations. Outbound calls are not affected.
Posted May 17, 2023 - 07:26 MDT