Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Talk Desk Outage
Incident Report for Hunter Douglas IT
Resolved
Talkdesk has resolved the outage.
Posted Sep 21, 2023 - 12:14 MDT
Update
We are still experiencing an issue with Talkdesk dropped calls, There have been improvements in receiving calls. No ETR.
Posted Sep 21, 2023 - 11:22 MDT
Investigating
We are currently experiencing an issue with Talkdesk dropped calls, and support tickets have been opened with both Talkdesk and Lumen, the 3rd party vendor. No ETR.
Posted Sep 21, 2023 - 08:59 MDT