Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Comfortex (Watervliet) Power Outage
Incident Report for Hunter Douglas IT
Resolved
Support teams have resolved the power outage affecting the file server and shop floor MII servers at Comfortex (Watervliet).
Posted Aug 08, 2023 - 13:18 MDT
Investigating
We are currently investigating a power outage affecting the file server and MII stack at Comfortex (Watervliet). No ETR.
Posted Aug 08, 2023 - 11:56 MDT
This incident affected: Comfortex (ME/MII, Network, Shipping, Power).