Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal

Agua Prieta ME/MII Outage

Incident Report for Hunter Douglas IT

Resolved

Support teams have resolved the issue.
Posted Jun 05, 2023 - 17:59 MDT

Investigating

We are currently investigating very slow printing for all buildings.
Posted Jun 05, 2023 - 16:58 MDT
This incident affected: Agua Prieta (ME/MII).