Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal

McKinney Power Outage

Incident Report for Hunter Douglas IT

Resolved

Power has been restored in McKinney. Support will continue to closely monitor but please contact the Service Desk if any new issues arise.
Posted Jun 23, 2023 - 21:59 MDT

Identified

The local power company, Oncor, is reporting a power outage. ETR is 7 pm MT.
Posted Jun 23, 2023 - 17:02 MDT
This incident affected: McKinney (Network, ME/MII, Shipping, Power).