Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
5/30 Shipping Stations Down in AP
Incident Report for Hunter Douglas IT
Resolved
Support teams have resolved the shipping issue.
Posted May 30, 2024 - 19:35 MDT
Investigating
We are currently investigating an issue with shipping in Agua Prieta.
Posted May 30, 2024 - 19:13 MDT
This incident affected: Agua Prieta (Shipping).