Welcome to HD's Status Page

Here you'll find real-time information on outages and scheduled maintenance.

Service Desk Portal
Rosarito (ILM) ME/MII Outage
Incident Report for Hunter Douglas IT
Resolved
The server issue affecting the file server and shop floor servers at Rosarito (ILM) has been resolved.
Posted Aug 24, 2023 - 21:18 MDT
Identified
We are currently investigating a power outage affecting the file server and shop floor MII servers at Rosarito (ILM). Not ETR.
Posted Aug 24, 2023 - 20:14 MDT
This incident affected: Rosarito (ME/MII).